Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > Ram Srt-10 Racing
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

Ram Srt-10 Racing

#NothingButProblems


This is a discussion on #NothingButProblems within the Ram Srt-10 Racing forums, part of the Viper Truck SRT-10 Discussion category!
****UPDATE**** So after 2 years of this truck sitting due to work/life obligations, I recently bought and installed a new ...



Like Tree7Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09-02-2017, 09:28 AM
Stupuff's Avatar
Member
 
Join Date: Jan 2010
Location: Ontario, Canada
Age: 31
Posts: 139
Member #11283
#NothingButProblems

****UPDATE****

So after 2 years of this truck sitting due to work/life obligations, I recently bought and installed a new (low vacuum) bypass valve from kenne-bell thinking that this has a lot to do with my issues with my new cam.

Once I started the truck, it started ticking pretty bad... Had very low oil pressure out of nowhere. Looks like no oil pressure now...

I haven't driven the truck far at all (luckily) and am wondering if anyone else has had a sudden loss of oil pressure or similar issues...

Just to be sure i did do an oil change to make sure the appropriate amount of oil was in the engine but it didn't change anything...

How common is an oil pump failure or the pickup tube falling off?

Brad was right, #NOTHINGBUTPROBLEMS

__________________
-Stupuff

"BOOM, HEADSHOT"

*****2004 SRT10 RAM reg cab. ROE supercharged. meth injected. and a lumpy ROE camshaft. 698hp on 91octane*****
Reply With Quote
  #2 (permalink)  
Old 09-02-2017, 10:32 AM
VENOMOUS1 RACING's Avatar
VIPER POWERED
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 43
Posts: 12,623
Member #10675
Sounds like a spun bearing boss. Oil pumps never are issue. There's also an oil pressure relief valve that could have gotten stuck and not allowing pressure.
__________________
"OFTEN imitated, NEVER duplicated"

Home of the SuperSnake hoods NOW AVAILABLE! :
Venomous1 Racing Traction/Transfer Systems coming to an SRT-10 near you
Venomous1 Racing Underdrive Pulleys for Gen3 SRT-10 Viper Trucks and Coupes available now!!

** 1 OF 5 2005 SRT-10 Quad Cab Tremec T56
Equipped**
Home of the First and Fastest 6 Speed SRT10 Quad Cab...The VENOMOUS1

Your Viper Coupe and Truck go fast and appearance parts GO-TO guy!!
Reply With Quote
  #3 (permalink)  
Old 09-02-2017, 01:22 PM
Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 390
Member #15071
Just had this issue but dont know what the cause is yet. Motor is pulled. Bearings are toast so are pistons and at least 4 lifters i lost oil pressure out of no where doing 130mph
Reply With Quote
  #4 (permalink)  
Old 09-02-2017, 04:16 PM
Stupuff's Avatar
Member
 
Join Date: Jan 2010
Location: Ontario, Canada
Age: 31
Posts: 139
Member #11283
i lost pressure at idle basically after storage...
__________________
-Stupuff

"BOOM, HEADSHOT"

*****2004 SRT10 RAM reg cab. ROE supercharged. meth injected. and a lumpy ROE camshaft. 698hp on 91octane*****
Reply With Quote
  #5 (permalink)  
Old 09-02-2017, 04:16 PM
Stupuff's Avatar
Member
 
Join Date: Jan 2010
Location: Ontario, Canada
Age: 31
Posts: 139
Member #11283
how do i check to see if the bypass is the issue?
__________________
-Stupuff

"BOOM, HEADSHOT"

*****2004 SRT10 RAM reg cab. ROE supercharged. meth injected. and a lumpy ROE camshaft. 698hp on 91octane*****
Reply With Quote
  #6 (permalink)  
Old 09-03-2017, 12:23 PM
Psycho1122's Avatar
Almost Senior Member
Southwest VTCoA Regional Member
 
Join Date: Jan 2010
Location: The "Crazy" Far East part of Mesa, AZ
Posts: 787
Member #11268
Quote:
Originally Posted by Stupuff View Post
i lost pressure at idle basically after storage...
Rear / Rotor oil pumps do not like cavitation.

Sitting TWO years without starting is quite a long timeframe. Anything over 4 days is considered an official "Dry Start" by aviation standards on a wet sump lubrication system. It is possible that your oil pump lost its prime after extended period of sitting.

I always "prime" my engine with the starter at 200+ RPM and the fuel relay unplugged. Always after sitting more than 4 days or after an oil & filter change.

Good luck with your engine issue.

Quote:
Originally Posted by IronAffliction View Post
Just had this issue but dont know what the cause is yet. Motor is pulled. Bearings are toast so are pistons and at least 4 lifters i lost oil pressure out of no where doing 130mph
What were your driving and engine conditions at 130? (High speed sweeper, Oil / engine temp, oil level prior to the drive, oil viscosity)

Cheers
__________________
2005 Black RC Born on April, 22nd., 16th hour of 2005: BBK, JTSVP Gen II Shifter, JTSVP Under Drive Pulley, K&N Drop-In, Demon Coils, B&B Manifold Back Exhaust w/ Hi flow Cats, SCT Tuned by Torrie, RX Monster Catch Can, JMB QA1 "kicker" shock, Polyurethane Suspension / Sway bar Bushings, AEM Wideband, Raptor Shift Light, Dynamat Interior, JTSVP Oil Cooler lines, 70/30 DiH2O/Dexcool Mix w/ Water Wetter, ALL fluids Synthetic and a few "sneaky" aero mods

2000 ZX1270R, 200 H.P. / 111 Ft. Lbs.
Reply With Quote
  #7 (permalink)  
Old 09-03-2017, 12:29 PM
Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 390
Member #15071
What were your driving and engine conditions at 130? (High speed sweeper, Oil / engine temp, oil level prior to the drive, oil viscosity)

Cheers[/QUOTE]

Engine temp 170. Oil level perfect. Running 0-40. Driving conditions long flat strait road about 80 outside.
Reply With Quote
  #8 (permalink)  
Old 09-03-2017, 12:29 PM
Slitherbeast's Avatar
Twin Turbo, Forged
Canadian VTCoA Regional Member
 
Join Date: Sep 2007
Location: Alberta
Posts: 2,201
Member #2340
install a manual oil pressure gauge to be sure the electric gauge isn't faulty...... If you have little to no oil pressure, that engine has to come out. That NEW timing cover may be the problem.
Psycho1122 and Stupuff like this.
__________________
"Haters don't really hate you, they hate themselves cause you're a reflection of what they wish to be".


#993 04 blk RC 4.56 gears,Harland Sharp Rockers,3/8" Hardened Pushrods, PSI Valve Springs,,Striker Valve Cover Spacers, JMB catless mids,Magnaflow Catback, Torries' Tune,B&M Shifter,Stinker's Extreme Lowering Kit, Caltracs,Catchcan, Forged Wiseco Pistons,Molnar Rods, Clevite Bearings.Center Force Clutch,Cometics Head Gaskets,ARP Head Studs , Pioneer X950BH Double Din , Grants Steering Wheel .And the list continues......
Reply With Quote
  #9 (permalink)  
Old 09-03-2017, 12:42 PM
VENOMOUS1 RACING's Avatar
VIPER POWERED
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 43
Posts: 12,623
Member #10675
Pressure relief cartridge is on driver side of timing cover. Remove and clean it of any debris and reinstall. Like above mentioned, pull fuel pump relay and spin over engine noting oil pressure. If it pressures up on gauge go ahead and fire it up briefly and see if pressure exist and lifters are quiet. If you have another timing cover try the cartridge from
It and compare results. Best of luck
Stupuff likes this.
__________________
"OFTEN imitated, NEVER duplicated"

Home of the SuperSnake hoods NOW AVAILABLE! :
Venomous1 Racing Traction/Transfer Systems coming to an SRT-10 near you
Venomous1 Racing Underdrive Pulleys for Gen3 SRT-10 Viper Trucks and Coupes available now!!

** 1 OF 5 2005 SRT-10 Quad Cab Tremec T56
Equipped**
Home of the First and Fastest 6 Speed SRT10 Quad Cab...The VENOMOUS1

Your Viper Coupe and Truck go fast and appearance parts GO-TO guy!!
Reply With Quote
  #10 (permalink)  
Old 09-03-2017, 02:22 PM
Member
 
Join Date: Apr 2017
Posts: 316
Member #16573
Got any pics of this Scott? Is this something we should do as a routine maintenance?
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On






All times are GMT -4. The time now is 11:48 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum