Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > Ram Srt-10 Racing
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

Ram Srt-10 Racing

#NothingButProblems


This is a discussion on #NothingButProblems within the Ram Srt-10 Racing forums, part of the Viper Truck SRT-10 Discussion category!
i will look into the bypass cartridge and i'll take a look at the "old" one i have... I have ...



Like Tree7Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 09-03-2017, 08:45 PM
Stupuff's Avatar
Member
 
Join Date: Jan 2010
Location: Ontario, Canada
Age: 31
Posts: 139
Member #11283
i will look into the bypass cartridge and i'll take a look at the "old" one i have...

I have pulled the fuel pump relay and rolled it over, no change to the gauge on the dash. i've seen chevy gear driven oil pumps fail before (less than ideal output) but not completely like this...

__________________
-Stupuff

"BOOM, HEADSHOT"

*****2004 SRT10 RAM reg cab. ROE supercharged. meth injected. and a lumpy ROE camshaft. 698hp on 91octane*****
Reply With Quote
  #12 (permalink)  
Old 09-03-2017, 08:48 PM
Stupuff's Avatar
Member
 
Join Date: Jan 2010
Location: Ontario, Canada
Age: 31
Posts: 139
Member #11283
Quote:
Originally Posted by Slitherbeast View Post
install a manual oil pressure gauge to be sure the electric gauge isn't faulty...... If you have little to no oil pressure, that engine has to come out. That NEW timing cover may be the problem.
where is an easy place to tie in? oil filter sandwich plate? block?
__________________
-Stupuff

"BOOM, HEADSHOT"

*****2004 SRT10 RAM reg cab. ROE supercharged. meth injected. and a lumpy ROE camshaft. 698hp on 91octane*****
Reply With Quote
  #13 (permalink)  
Old 09-04-2017, 09:13 AM
ARRESTmeRed04's Avatar
VIPER POWERED
Southwest VTCoA Regional Member
 
Join Date: Nov 2007
Location: central texas
Age: 32
Posts: 5,878
Member #2894
Quote:
Originally Posted by Stupuff View Post
where is an easy place to tie in? oil filter sandwich plate? block?
Stick a tee where the factory oil pressure sensor is
Stupuff and VPRPWRD like this.
Reply With Quote
  #14 (permalink)  
Old 09-04-2017, 11:17 AM
Psycho1122's Avatar
Almost Senior Member
Southwest VTCoA Regional Member
 
Join Date: Jan 2010
Location: The "Crazy" Far East part of Mesa, AZ
Posts: 780
Member #11268
Quote:
Originally Posted by Slitherbeast View Post
install a manual oil pressure gauge to be sure the electric gauge isn't faulty...... If you have little to no oil pressure, that engine has to come out. That NEW timing cover may be the problem.
Ah Yes! The NEW timing cover. Excellent point. I would also make sure the oil pick up tube o-ring was not compromised upon installation.

Quote:
Originally Posted by IronAffliction View Post
What were your driving and engine conditions at 130? (High speed sweeper, Oil / engine temp, oil level prior to the drive, oil viscosity)

Cheers
Engine temp 170. Oil level perfect. Running 0-40. Driving conditions long flat strait road about 80 outside.[/QUOTE]

I will be interested in your forensics on this engine failure.

Quote:
Originally Posted by ARRESTmeRed04 View Post
Stick a tee where the factory oil pressure sensor is
This is exactly where the OEM recommends checking pressure. Good luck on your findings.

Cheers!
Stupuff likes this.
__________________
2005 Black RC Born on April, 22nd., 16th hour of 2005: BBK, JTSVP Gen II Shifter, JTSVP Under Drive Pulley, K&N Drop-In, Demon Coils, B&B Manifold Back Exhaust w/ Hi flow Cats, SCT Tuned by Torrie, RX Monster Catch Can, JMB QA1 "kicker" shock, Polyurethane Suspension / Sway bar Bushings, AEM Wideband, Raptor Shift Light, Dynamat Interior, JTSVP Oil Cooler lines, 70/30 DiH2O/Dexcool Mix w/ Water Wetter, ALL fluids Synthetic and a few "sneaky" aero mods

2000 ZX1270R, 200 H.P. / 111 Ft. Lbs.
Reply With Quote
  #15 (permalink)  
Old 09-04-2017, 11:31 PM
Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 364
Member #15071
Can't get the cover off for the oil pump thats all thats left that could create that much metal in my motor
Reply With Quote
  #16 (permalink)  
Old 09-05-2017, 06:27 PM
Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 364
Member #15071
Got the cover off oil pump was not the issue it is fine
Reply With Quote
  #17 (permalink)  
Old 09-08-2017, 09:50 AM
Slitherbeast's Avatar
Twin Turbo, Forged
Canadian VTCoA Regional Member
 
Join Date: Sep 2007
Location: Alberta
Posts: 2,194
Member #2340
gotta go deeper..... Is the oil pickup cracked or missing? pretty rare that an engine loses pressure like you have described. was there any oil in the engine? did a hose fail and pump the engine dry?
Psycho1122 likes this.
__________________
"Haters don't really hate you, they hate themselves cause you're a reflection of what they wish to be".


#993 04 blk RC 4.56 gears,Harland Sharp Rockers,3/8" Hardened pushrods PSI valve Springs,,striker Valve Cover spacers, JMB catless mids,Magnaflow catback, Torries' tune,Vec 2,B&M Shifter,Stinker's extreme lowering kit, Caltracs,catchcan, Forged Wiseco Pistons,Molnar Rods, Clevite bearings.Center Force Clutch,Cometics Head Gaskets,ARP head Studs , Pioneer X950BH Double Din touch screen with Nav , Grants Steering Wheel .And the list continues......
Reply With Quote
  #18 (permalink)  
Old 09-08-2017, 01:12 PM
Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 364
Member #15071
The motor is out and a bare block now. I lost a bolt from the caps that hold the lifters in place and 4 others were were loose other than that no everything was fine besides the crap ton of metal shavings in the pan
Reply With Quote
  #19 (permalink)  
Old 09-13-2017, 04:42 PM
Slitherbeast's Avatar
Twin Turbo, Forged
Canadian VTCoA Regional Member
 
Join Date: Sep 2007
Location: Alberta
Posts: 2,194
Member #2340
Where did the shavings come from?
__________________
"Haters don't really hate you, they hate themselves cause you're a reflection of what they wish to be".


#993 04 blk RC 4.56 gears,Harland Sharp Rockers,3/8" Hardened pushrods PSI valve Springs,,striker Valve Cover spacers, JMB catless mids,Magnaflow catback, Torries' tune,Vec 2,B&M Shifter,Stinker's extreme lowering kit, Caltracs,catchcan, Forged Wiseco Pistons,Molnar Rods, Clevite bearings.Center Force Clutch,Cometics Head Gaskets,ARP head Studs , Pioneer X950BH Double Din touch screen with Nav , Grants Steering Wheel .And the list continues......
Reply With Quote
  #20 (permalink)  
Old 09-14-2017, 09:42 AM
Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 364
Member #15071
From the bearings and the few lifters that got messed up and the pistons
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 6 (0 members and 6 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On






All times are GMT -4. The time now is 09:46 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum