Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Main Forum > New Members Section
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

New Members Section

New to forum


This is a discussion on New to forum within the New Members Section forums, part of the Main Forum category!
Hey y'all I've had my silver 05 qc for about a year. Just found this forum the other day. Love ...



Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-26-2018, 10:18 PM
You got a Hemi?
 
Join Date: Jan 2018
Location: Amarillo texas
Posts: 9
Member #18276
New to forum

Hey y'all I've had my silver 05 qc for about a year. Just found this forum the other day. Love the truck...just have some questions about it every other day or so...for instance where is my oil going? No leaks...running about 180-205 coolant temp, 180 -200 oil temp. Good pressure. Basicly dry on dipstick. Any ideas?

Reply With Quote
  #2 (permalink)  
Old 01-27-2018, 01:08 AM
Junior Member
 
Join Date: Jan 2018
Posts: 62
Member #18271
Maybe look underneath it and see if oil is leaking from the back of the valve cover gaskets then burning off on exhaust pipes. Your gonna burn a quart of oil every 2000 miles in normal driving conditions. Mopar V10s and V8 hemis all burn a little oil. How much oil are you loosing? I'm a newb to the srt10 community someone here will chime in sooner or later.

Oil cooler lines?
Reply With Quote
  #3 (permalink)  
Old 01-27-2018, 09:37 AM
VENOMOUS1 RACING's Avatar
Has Left the Room - Banned from VTCOA!
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 44
Posts: 12,753
Member #10675
Our oil cooler lines are prone to leaking yet weaping and getting blown all over underside and yet never drip to floor. Make sure it's always registering on dipstick!! Mopar filter and 15/50 Mobil 1.

Last edited by ViperJeff; 01-27-2018 at 01:13 PM. Reason: Not a Vendor
Reply With Quote
  #4 (permalink)  
Old 01-27-2018, 09:43 AM
You got a Hemi?
 
Join Date: Jan 2018
Location: Amarillo texas
Posts: 9
Member #18276
It calls for 0-40, do you use different?.and I'll check the valve covers. I appreciate the info.
Reply With Quote
  #5 (permalink)  
Old 01-27-2018, 11:37 AM
Almost Senior Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 558
Member #15071
Could be a broken valve guide.
Reply With Quote
  #6 (permalink)  
Old 01-27-2018, 12:35 PM
You got a Hemi?
 
Join Date: Jan 2018
Location: Amarillo texas
Posts: 9
Member #18276
How would I go about checking that?
Reply With Quote
  #7 (permalink)  
Old 01-27-2018, 01:36 PM
Almost Senior Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 558
Member #15071
Pull the intake pull the heads remove valves and check the guides. Mine was doing this awhile back and had a broken valve guide
silverqc87 likes this.
Reply With Quote
  #8 (permalink)  
Old 01-27-2018, 01:55 PM
Almost Senior Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 558
Member #15071
I would double check the block first make sure its not leaking somewhere else
silverqc87 likes this.
Reply With Quote
  #9 (permalink)  
Old 01-27-2018, 06:27 PM
You got a Hemi?
 
Join Date: Jan 2018
Location: Amarillo texas
Posts: 9
Member #18276
I went ahead and did an oil change and it has been sitting for 6 months but I only pulled maybe 6.5 quarts out and filled back with 9. Cleaned the engine and will check for leaks over the next couple of days. I appreciate you guys input. I'll update once I figure it out.
Reply With Quote
  #10 (permalink)  
Old 01-28-2018, 09:46 AM
Psycho1122's Avatar
Almost Senior Member
Southwest VTCoA Regional Member
 
Join Date: Jan 2010
Location: The "Crazy" Far East part of Mesa, AZ
Posts: 909
Member #11268
Quote:
Originally Posted by ToneDef View Post
Maybe look underneath it and see if oil is leaking from the back of the valve cover gaskets then burning off on exhaust pipes. Your gonna burn a quart of oil every 2000 miles in normal driving conditions. Mopar V10s and V8 hemis all burn a little oil. How much oil are you loosing? I'm a newb to the srt10 community someone here will chime in sooner or later.

Oil cooler lines?
IF you were burning oil anywhere around the engine, you would smell it. It is NOT normal for our V10's to burn oil. Disregard the quart every 2000 miles comment. Mine has not burned any oil in 8 years of ownership.

Quote:
Originally Posted by silverqc87 View Post
It calls for 0-40, do you use different?.and I'll check the valve covers. I appreciate the info.
Yes, use the 0W40 Mobil1 "FS" European Car formula. Rated top 5 for wear protection. If anything, it's still a bit on the thick side. The link below is a LONG read. However, no MYTH's, just facts. Your view oil oils and oiling will be affected dramatically. See here...

https://540ratblog.wordpress.com/201...-test-ranking/


Quote:
Originally Posted by IronAffliction View Post
Could be a broken valve guide.
Lets just say that the broken valve guide is possible, you would have oil burning at start up. Smoke out of exhaust at start up? Synthetics tend not to smoke blue. Try a high quality dino oil. Let it sit overnight and see if it smokes on next start.

I'd look at the crankcase breather system. Our trucks do not have an oil separator. Crankcase fumes and pressure get sucked into the intake. A simple check would be to pull your throttle body and see how oily your intake manifold is. If you do not find an external leak or drip, I'd bet you have serious blow by and your engine is choking it down. Another reason the OEM runs these engines over rich. To counter act the low octane oil fumes.

Good Luck! Cheers
silverqc87 likes this.
__________________
2005 Black RC Born on April, 22nd., 16th hour of 2005: BBK, JTSVP Gen II Shifter, JTSVP Under Drive Pulley, K&N Drop-In, Demon Coils, B&B Manifold Back Exhaust w/ Hi flow Cats, SCT Tuned by Torrie, RX Monster Catch Can, JMB QA1 "kicker" shock, Polyurethane Suspension / Sway bar Bushings, AEM Wideband, Raptor Shift Light, Dynamat Interior, JTSVP Oil Cooler lines, 70/30 DiH2O/Dexcool Mix w/ Water Wetter, ALL fluids Synthetic and a few "sneaky" aero mods

2000 ZX1270R, 200 H.P. / 111 Ft. Lbs.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Dodge Truck Forum yellowfever110 Non-Offensive 25 10-17-2008 09:55 PM
Its a Forum right? Nowwhat Performance Mods 76 06-03-2007 11:22 PM
What's Going On In The Other Vehicle Forums! Kevan Non-Offensive 17 08-07-2006 11:46 PM





All times are GMT -4. The time now is 08:09 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum