Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Main Forum > New Members Section
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

New Members Section

New to forum


This is a discussion on New to forum within the New Members Section forums, part of the Main Forum category!
Mine never showed signs of burning oil at start up or any other time but i was losing oil....



Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 01-28-2018, 11:49 AM
Almost Senior Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 563
Member #15071
Mine never showed signs of burning oil at start up or any other time but i was losing oil.

Reply With Quote
  #12 (permalink)  
Old 01-28-2018, 01:02 PM
Member
 
Join Date: Nov 2017
Location: South
Posts: 135
Member #18022
Welcome to the "Wild Bunch"!
Reply With Quote
  #13 (permalink)  
Old 01-30-2018, 10:39 AM
Kopack_05's Avatar
Member
 
Join Date: May 2014
Location: Florida
Posts: 154
Member #14634
I'm with Venomous1. If he has not replaced his oil cooler lines. They are most likely leaking. It took a while for me to notice the light weight synthetic oil leaving a spot in the garage.

Although its tough to think that one of these trucks that have been driven, still have the factory lines.

I bought mine with 6K on it and replaced the lines at 8k. Just did the power steering lines at 15k.

Check behind the throttle body.
Reply With Quote
  #14 (permalink)  
Old 01-30-2018, 03:57 PM
You got a Hemi?
 
Join Date: Jan 2018
Location: Amarillo texas
Posts: 9
Member #18276
No smoke anytime...i had the throttle body off and cleaned when I did an entire fuel system cleaning done and there was very little inside manifold. It looked almost brand new in there actually. A little build up from the dirty throttle body bit that's it. Didn't even smoke when we ran the cleaner through the top end...im getting it's a valve cover gasket..
Reply With Quote
  #15 (permalink)  
Old 01-30-2018, 04:53 PM
Almost Senior Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 563
Member #15071
Ya could always do the valve cover gasket first cheap and easy. I would get under the truck and check for oil anywhere
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Dodge Truck Forum yellowfever110 Non-Offensive 25 10-17-2008 10:55 PM
Its a Forum right? Nowwhat Performance Mods 76 06-04-2007 12:22 AM
What's Going On In The Other Vehicle Forums! Kevan Non-Offensive 17 08-08-2006 12:46 AM





All times are GMT -4. The time now is 07:28 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum