Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Main Forum > New Members Section
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

New Members Section

NEW GUY FROM WI.


This is a discussion on NEW GUY FROM WI. within the New Members Section forums, part of the Main Forum category!
I own a 2006, Inferno Red Quad Cab. 113,000 miles. Beautiful shape. I have a question for you srt v10 ...



Like Tree1Likes
  • 1 Post By cagey2

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12-28-2018, 12:23 PM
You got a Hemi?
 
Join Date: Dec 2018
Posts: 4
Member #20176
NEW GUY FROM WI.

I own a 2006, Inferno Red Quad Cab. 113,000 miles. Beautiful shape.

I have a question for you srt v10 owners: Some times when I power it up the check guages lite shows up on my dash and the steering wheel turns very hard. then it gets better and the light goes off and everything is fine. Seems to do this when it is wet out. I put on a new serpentine belt and power steering pressure lines and fittings. But yesterday I started the truck again and the same thing happened with the check gauges lite and steering wheel would not turn.????? Has anyone had this problem????:
GSJake likes this.

Reply With Quote
  #2 (permalink)  
Old 12-28-2018, 02:15 PM
trussman's Avatar
VIPER POWERED
Southeast VTCoA Regional Member
 
Join Date: Aug 2007
Location: Jacksonville, NC
Age: 36
Posts: 4,028
Member #2161
Send a message via Yahoo to trussman
Mine does it all the time. I lightly rev a few times to dry the belt. If you notice when this happens the voltage gauge likely goes to 0 as well. Mine does it every time it rains or when I wash it. Has for the last 12 years.
__________________
Built by Royal purple. 501 hp/609 tq.
Reply With Quote
  #3 (permalink)  
Old 12-29-2018, 12:57 AM
Shaggy's Avatar
Administrator
 
Join Date: Aug 2010
Location: Arizona
Age: 42
Posts: 942
Member #11756
Quote:
Originally Posted by cagey2 View Post
I own a 2006, Inferno Red Quad Cab. 113,000 miles. Beautiful shape.

I have a question for you srt v10 owners: Some times when I power it up the check guages lite shows up on my dash and the steering wheel turns very hard. then it gets better and the light goes off and everything is fine. Seems to do this when it is wet out. I put on a new serpentine belt and power steering pressure lines and fittings. But yesterday I started the truck again and the same thing happened with the check gauges lite and steering wheel would not turn.????? Has anyone had this problem????:
Does sound like a belt slipping issue like @trussman mentioned. Welcome to the site BTW. Post up pics of your truck when you can.
__________________


Dodge Ram Forum | Jeep Forum | Chevy Tahoe Forum | Land Rover Forum | Chevy Cobalt Forum | GM Truck Forum
Corvette Forum | LX Forum | Nissan Titan Forum | Scion xD Forum | '88 - '98 GM Truck Forum | Chevy Camaro Forum
Ford Raptor Forum | Scion xB Forum | Scion TC Forum | Mazda Rx7 Forum | Chevy Equinox Forum | Ford Expedition Forum
Truck Mod Forum | Viper Car Forum | Chevy Tahoe Forum | Jeep Liberty Forum | '73 - '87 GM Truck Forum | Ford Truck Forum
Dodge Challenger Forum | Land Rover Forum | Dodge Dart Forum | Scion FR-S Forum | Dodge Ram SRT10 Forum | Dodge SRT Forum
Regional Forums -- Dallas Fort Worth Mustang Forum | Indiana Truck Forum | South East Mopar Forum | Oklahoma Ram Forum
---------------------------------------------------------------------------------------------------------------
Weapons Forum | ATV Forum | Classic Rock Forum | Offtopic Forum
Reply With Quote
  #4 (permalink)  
Old 12-29-2018, 10:42 AM
You got a Hemi?
 
Join Date: Dec 2018
Posts: 4
Member #20176
Quote:
Originally Posted by trussman View Post
Mine does it all the time. I lightly rev a few times to dry the belt. If you notice when this happens the voltage gauge likely goes to 0 as well. Mine does it every time it rains or when I wash it. Has for the last 12 years.
Thank you for the response. I will try the reving next time. I usually try turning the wheel back and forth till it becomes free. Do you think it could possible be the belt tensioner being weak?
Reply With Quote
  #5 (permalink)  
Old 12-29-2018, 11:40 AM
You got a Hemi?
 
Join Date: Dec 2018
Posts: 4
Member #20176
Thank you Shaggy for your response. I just added some pics of my truck..
Reply With Quote
  #6 (permalink)  
Old 12-29-2018, 12:40 PM
rottenronnie's Avatar
VIPER POWERED
Canadian VTCoA Regional Member
 
Join Date: Jul 2006
Location: Calgary, Alberta
Posts: 2,446
Member #345
The pulley is likely still turning on the belt-tensioner, but can the arm still move?
If it cant, replace the tensioner assembly.
__________________
2005 QC N.A.
624 Wheel HP x 1.27 = 800-'ish flywheel (?)
Fully-Built 11:1 Pump-Gas
15.0 L/100 km. or 15.68 U.S. Miles Per Gallon
5600 pounds
[email protected] MPH in "D" for Drive

No Power Adders
Full B&B Exhaust with (4) Cats
Unported Street-Striker Heads w Custom Roller
Unported O.E.M. Intake Manifold
FSTJACK Hand-Ported TB
MONSTER R/X Dual-Vacuum Catch-Can
A fully-built 48RE transmission that actually keeps working!
Tuned by Maestro Chris Jensen
Reply With Quote
  #7 (permalink)  
Old 12-29-2018, 01:04 PM
Member
 
Join Date: Oct 2014
Location: Denver, CO
Posts: 176
Member #14796
Welcome to the VTCOA all the way from the Mile High City.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Guy Camp Pendleton ViperSmokedYou New Members Section 16 02-17-2013 10:51 PM
This guy on here? Snakes709 Ram Srt-10 Racing 33 05-16-2011 03:02 PM
New guy from Natzifornia Undercover86 New Members Section 16 11-30-2010 01:00 AM
Found a new florida guy Midnight Runner General Discussion 6 07-28-2010 02:20 AM
Just a new guy! MR ED's SRT10 New Members Section 12 06-26-2006 05:51 PM





All times are GMT -4. The time now is 10:36 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum