Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > General Discussion
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

General Discussion

Baffled!! Need advise


This is a discussion on Baffled!! Need advise within the General Discussion forums, part of the Viper Truck SRT-10 Discussion category!
I was driving home this afternoon when I was at a light and smelled gas. I look in the rearview ...




Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10-24-2009, 06:22 PM
jimmyg79's Avatar
Member
 
Join Date: May 2006
Location: Michigan
Posts: 125
Member #159
Baffled!! Need advise

I was driving home this afternoon when I was at a light and smelled gas. I look in the rearview mirror and see excessive smoke belowing out, the I notice my A/F gauge is reading a steady 12.7-13.1 which is odd, being that it's usualy jumping all over the map at idle, and then the check engine light goes on. I get home and check the codes and I end up pulling three. The first one read P0304, which is a misfire in cyl. 4. The second was P0204 which is the injector 4 control circuit, and then I had a P0158 which is a HO2S curcuit high voltage bank 2 censor 2.

I then disconected the battery and let it sit for a while, I hooked it up again and started the engine and everything looked and ran fine. I take it for a test drive and by the time I get to the end of our sub the check engine light comes on and it starts running rich again. I get back and check the code and this time it just gave me the P0204 which is the injector code. I reset it again and let it idle for about 10 minutes without any issue and took it for another test drive. I went about the same distance and it did it again. So I'm confused, is this an ECM problem, a wiring problem, or an injector problem? It seems like it will idle fine, but as soon as I drive it, it fouls up at almost the exact distance. Any ideas?

__________________
#845
04 Red

Diamond Forged Pistons
708 Gen III Cam
Bellanger Long Tube Headers
Bellanger HI-Flow Cats
Borla Cat Back Exhaust
NX Dual Nozzle Kit
Reply With Quote
  #2 (permalink)  
Old 10-24-2009, 06:33 PM
ARRESTmeRed04's Avatar
VIPER POWERED
Southwest VTCoA Regional Member
 
Join Date: Nov 2007
Location: central texas
Age: 32
Posts: 5,877
Member #2894
have you tried to run it at a constant RPM while parked in your driveway to see if it does it after a bit?
__________________
Red 04 ram srt10....10's
Silver 09 CTS-V.......12's
Reply With Quote
  #3 (permalink)  
Old 10-24-2009, 06:40 PM
Hatedonmostly's Avatar
Has Left the Room - Banned from VTCOA!
 
Join Date: May 2009
Location: Glen Burnie, Maryland
Posts: 1,100
Member #10726
Could be your pcm, when it comes to eletroincs anything can happen, Something is def wrong with your fuel it seems like. I have a extra 04 pcm if you want it to throw in with your vin and see if that helps ya. If you want it let me know buddy, I try to help anyone out if I can.
Reply With Quote
  #4 (permalink)  
Old 10-24-2009, 06:40 PM
jimmyg79's Avatar
Member
 
Join Date: May 2006
Location: Michigan
Posts: 125
Member #159
I'll go out there right now and see how long I can keep it at 1500 rpms before it goes rich.
__________________
#845
04 Red

Diamond Forged Pistons
708 Gen III Cam
Bellanger Long Tube Headers
Bellanger HI-Flow Cats
Borla Cat Back Exhaust
NX Dual Nozzle Kit
Reply With Quote
  #5 (permalink)  
Old 10-24-2009, 06:54 PM
jimmyg79's Avatar
Member
 
Join Date: May 2006
Location: Michigan
Posts: 125
Member #159
Ok, just kept it at 1500 rpm in the driveway and it fouled up in about the exact same time it did the previous times. At least it's only throwing the one P0204 code. You think the injector could just be stuck open and it just takes a little time for the computer to catch it? Which injector is 04?
__________________
#845
04 Red

Diamond Forged Pistons
708 Gen III Cam
Bellanger Long Tube Headers
Bellanger HI-Flow Cats
Borla Cat Back Exhaust
NX Dual Nozzle Kit
Reply With Quote
  #6 (permalink)  
Old 10-24-2009, 07:12 PM
jimmyg79's Avatar
Member
 
Join Date: May 2006
Location: Michigan
Posts: 125
Member #159
Quote:
Originally Posted by Hatedonmostly
Could be your pcm, when it comes to eletroincs anything can happen, Something is def wrong with your fuel it seems like. I have a extra 04 pcm if you want it to throw in with your vin and see if that helps ya. If you want it let me know buddy, I try to help anyone out if I can.
Thanks for the offer, I might take you up on it if I can't figure out this injector.
__________________
#845
04 Red

Diamond Forged Pistons
708 Gen III Cam
Bellanger Long Tube Headers
Bellanger HI-Flow Cats
Borla Cat Back Exhaust
NX Dual Nozzle Kit
Reply With Quote
  #7 (permalink)  
Old 10-24-2009, 07:25 PM
ARRESTmeRed04's Avatar
VIPER POWERED
Southwest VTCoA Regional Member
 
Join Date: Nov 2007
Location: central texas
Age: 32
Posts: 5,877
Member #2894
it might be, when you first start the truck its in "closed loop" so it just runs on a set program, after a little bit it goes into "open loop" which is where it starts adjusting the A/F ratio acording to what is needed. does it smoke when you first start it up?
__________________
Red 04 ram srt10....10's
Silver 09 CTS-V.......12's
Reply With Quote
  #8 (permalink)  
Old 10-24-2009, 07:35 PM
jimmyg79's Avatar
Member
 
Join Date: May 2006
Location: Michigan
Posts: 125
Member #159
It sure does. Without reseting the PCM, the AF gauge is normal and then it shows it's running rich after it goes into the open loop. So would that mean the injector's stuck open? I guess I can swap it with an injector from my 03 viper to find out, right?
__________________
#845
04 Red

Diamond Forged Pistons
708 Gen III Cam
Bellanger Long Tube Headers
Bellanger HI-Flow Cats
Borla Cat Back Exhaust
NX Dual Nozzle Kit
Reply With Quote
  #9 (permalink)  
Old 10-24-2009, 07:48 PM
ARRESTmeRed04's Avatar
VIPER POWERED
Southwest VTCoA Regional Member
 
Join Date: Nov 2007
Location: central texas
Age: 32
Posts: 5,877
Member #2894
that'd be a lot of work to swap'em out but yeah that'd tell you. maybe you could tap the injector first to see if it starts working
__________________
Red 04 ram srt10....10's
Silver 09 CTS-V.......12's
Reply With Quote
  #10 (permalink)  
Old 10-24-2009, 07:53 PM
jimmyg79's Avatar
Member
 
Join Date: May 2006
Location: Michigan
Posts: 125
Member #159
good idea, I'll give that a shot tomorrow and let you know how it goes.
__________________
#845
04 Red

Diamond Forged Pistons
708 Gen III Cam
Bellanger Long Tube Headers
Bellanger HI-Flow Cats
Borla Cat Back Exhaust
NX Dual Nozzle Kit
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On






All times are GMT -4. The time now is 04:50 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum