Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > General Discussion
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

General Discussion

Bbk tb sticking


This is a discussion on Bbk tb sticking within the General Discussion forums, part of the Viper Truck SRT-10 Discussion category!
So I picked up this bbk Tb and now I'm having idle issues, so I removed it and milled some ...



Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-12-2017, 06:21 PM
Member
 
Join Date: Apr 2017
Posts: 316
Member #16573
Bbk tb sticking

So I picked up this bbk Tb and now I'm having idle issues, so I removed it and milled some channels for the bolts to sit flat and it's still hanging, once I kick it down several times it stops, I even torqued it in a X pattern! any fix to this ? I've emailed bbk and waiting on their response, and just cause I was dealing with this bs I broke the little clip to the cruise control fml!
Edit: I've loosened up the iac screws and no dice !


Last edited by Silver05; 06-12-2017 at 07:56 PM.
Reply With Quote
  #2 (permalink)  
Old 06-12-2017, 10:55 PM
68charger's Avatar
Member
Canadian VTCoA Regional Member
 
Join Date: Jan 2010
Location: alberta ca.
Posts: 294
Member #11265
on mine the blades weren't centered so i loosened them put feeler gauges in three spots around each blade then tighten them back down
__________________

Tuned by Chris Jensen
chris@christuned.com
Reply With Quote
  #3 (permalink)  
Old 06-13-2017, 12:43 AM
Member
 
Join Date: Apr 2017
Posts: 316
Member #16573
I'll try that next, do I have to buy 3 feeler gage kits? What size did you use ?

Last edited by Silver05; 06-13-2017 at 01:23 AM.
Reply With Quote
  #4 (permalink)  
Old 06-13-2017, 10:48 AM
68charger's Avatar
Member
Canadian VTCoA Regional Member
 
Join Date: Jan 2010
Location: alberta ca.
Posts: 294
Member #11265
i don't remember the size .002 or .003 i think i also took the blades out and sanded the edges as well. just make sure they are centered and not catching.
__________________

Tuned by Chris Jensen
chris@christuned.com
Reply With Quote
  #5 (permalink)  
Old 06-13-2017, 05:28 PM
Member
 
Join Date: Apr 2017
Posts: 316
Member #16573
Ok, today I've changed the bolts to Allen head cap screws, check the blades and there is barely any light all the way around, and actually I broke the clip to my Throttle cable and the screws I backed up were for the tps, I'm wondering if I shot myself in foot installing this , with the cables off the only way for the idle to go down from 2k rpms is to tap in the Throttle body
Reply With Quote
  #6 (permalink)  
Old 06-14-2017, 11:07 AM
Flat4bo's Avatar
Junior Member
 
Join Date: Sep 2016
Location: NH
Posts: 60
Member #15933
Everyone uses the JTVSP throttle body because of this issue. The only problem there is I ordered one literally 9 weeks ago and I still have not received it. Back ordered was an understatement. Sucks when there is no other option for throttle body so I just have to wait.
__________________
2006 RC SRT10
Reply With Quote
  #7 (permalink)  
Old 06-14-2017, 12:44 PM
Kopack_05's Avatar
Member
 
Join Date: May 2014
Location: Florida
Posts: 135
Member #14634
Quote:
Originally Posted by Silver05 View Post
Ok, today I've changed the bolts to Allen head cap screws, check the blades and there is barely any light all the way around, and actually I broke the clip to my Throttle cable and the screws I backed up were for the tps, I'm wondering if I shot myself in foot installing this , with the cables off the only way for the idle to go down from 2k rpms is to tap in the Throttle body
Can you feel the blades sticking?

If not then you may need to clean the IAC.

When I installed my JTSVP throttle body, The instructions specifically called out, how to, and importance of cleaning the IAC.

Also look up a post from Arska2. He explains very detailed how to reset the shifting and idle with an aftermarket throttle body.
Reply With Quote
  #8 (permalink)  
Old 06-14-2017, 10:01 PM
Member
 
Join Date: Apr 2017
Posts: 316
Member #16573
I did clean the IAC and no the blades feel clear I even took some aluminum polish and polished the TB, today it seemed to be back to normal
Reply With Quote
  #9 (permalink)  
Old 06-15-2017, 12:47 AM
rbabody's Avatar
Member
 
Join Date: Sep 2010
Posts: 366
Member #11773
If you have access to a good scan tool you can go I'm and reset the tps and iac without doing a battery disconnect and resetting all the adaptive's for the truck.

Doesn't anybody run a roe mono blade? Tonys is a choice not the only choice. I also had some issues but with some adjusting it works awesome.

Even a cheap code reader that show some live data should work.

Last edited by rbabody; 06-15-2017 at 12:53 AM. Reason: No spacing
Reply With Quote
  #10 (permalink)  
Old 06-22-2017, 12:55 AM
Member
 
Join Date: Apr 2017
Posts: 316
Member #16573
Well I'm still having this issue, I just disconnected the battery cables and all 3 pcm plugs, touched the battery cables and plugged the pcm back in and cables back on, is there another thing I need to do before I restart it ?
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
BBK TB, Stock TB, and Intake for sale!! mikeH SRT-10 Trucks and Parts For Sale 14 07-23-2017 09:33 AM
BBK TPS problem ViperPete Performance Mods 65 10-24-2013 10:32 AM
BBK TB for sale ramv10 SRT-10 Trucks and Parts For Sale 20 07-08-2013 07:40 PM
FS: SCT tuner, BBK throttle body, B&M shifter Vman455 SRT-10 Trucks and Parts For Sale 9 09-08-2010 07:24 PM
BBK TB jrangel General Discussion 17 04-29-2009 11:01 PM





All times are GMT -4. The time now is 10:14 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum