Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > General Discussion
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

General Discussion

Brake light on dash coming on


This is a discussion on Brake light on dash coming on within the General Discussion forums, part of the Viper Truck SRT-10 Discussion category!
I'm having an intermitent problem of the red brake warning light coming on in the dash. It is not the ...



Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07-11-2009, 03:22 PM
Junior Member
 
Join Date: Apr 2007
Location: Casa Grande ,AZ
Posts: 79
Member #1535
Brake light on dash coming on

I'm having an intermitent problem of the red brake warning light coming on in the dash. It is not the ABS one, it is the red one like when you put the parking brake on. It also chimes when it turns on too. It only happens when I leave work in the very hot afternoon a few miles from work any other time it doesn't come on. I know I just won't goto work anymore. I have checked fluid level ,and the parking brake to make sure it is fully up. Any other ideas? Thanks

__________________
93 454SS Kenne Bell 2.4L supercharged ,2002 Lightning Whipple 3.4L supercharged, 2006 QC Night Runner(Borla, BBK, K&N diesel, stage 2 flash ECM, 170 thermostat ,wing delete mod) ,95 2dr Tahoe 4WD Whipple 2.2L supercharged ,79 Tenth Anniversary Trans Am (400,4spd)53,000 miles, 63 Impala(21,000 orig. miles), 95 Banshee (Built)
Reply With Quote
  #2 (permalink)  
Old 07-11-2009, 03:24 PM
DevilDawg3097's Avatar
VIPER POWERED
 
Join Date: Jul 2008
Location: Windy City
Age: 45
Posts: 3,863
Member #6613
do you have a tune or flash? sometimes once in a while that happens to me but then it goes away. I dont beleive it is anything bad unless the sensor is getting ready to go.
__________________

It's my empire now BIOTCH!!
04 10lb Roe S/C 717hp 753tq
"God forbid we should ever be twenty years without such a rebellion.The people cannot be all, and always, well informed. The part which is wrong will be discontented, in proportion to the importance of the facts they misconceive. If they remain quiet under such misconceptions,it is lethargy, the forerunner of death to the public liberty.
Reply With Quote
  #3 (permalink)  
Old 07-11-2009, 07:58 PM
1qksrt's Avatar
VIPER POWERED
 
Join Date: Dec 2006
Posts: 2,021
Member #963
Try unplugging the sensor connector at the master cylinder,jump the connector and see if the light turns off,If it turns off,replace the switch.
Reply With Quote
  #4 (permalink)  
Old 03-24-2016, 08:59 AM
Humblex's Avatar
Almost Senior Member
 
Join Date: Mar 2011
Location: Virginia
Age: 41
Posts: 535
Member #12086
Has anyone found a solution to this problem? I have had this issue since day one but, only on warm to hot days. I have even replaced both front calipers, breaks, new fluid up front. Fluid level is good. Unplugged sensor and replugged with no sucess. Maybe the problem is where the emergency break actually engages?
Reply With Quote
  #5 (permalink)  
Old 03-24-2016, 09:24 AM
VPRPWRD's Avatar
VTCoA Ring Leader
Northeast VTCoA Regional Rep
 
Join Date: Mar 2012
Location: PA
Posts: 10,833
Member #13138
Quote:
Originally Posted by Humblex View Post
Has anyone found a solution to this problem? I have had this issue since day one but, only on warm to hot days. I have even replaced both front calipers, breaks, new fluid up front. Fluid level is good. Unplugged sensor and replugged with no sucess. Maybe the problem is where the emergency break actually engages?
I just recently posted in a similar thread that adjustment of the parking brake switch is what I have found causing this issue most of the time.
__________________
Quote:
Originally Posted by KyleB View Post
OMG, I think you're right! You're a genius, we should definitely put you in charge around here.
My YouTube channel:

http://www.youtube.com/channel/UCEsMsFATkTJq3k-BM26PfAg

Follow me on Twitter and Instagram: Andysavakinas



#1357 of 3057 2004 Dodge Ram SRT-10 SOLD!
#2718 of 3057 2004 Dodge Ram SRT-10
#0851 2006 Dodge Ram SRT-10 RC SOLD!
#292 of 3057 2004 Dodge Ram SRT-10 SOLD!

THE FORMER BUMP KING

i love the cognac interior of the gen1/gen2 viper. if i could do it to my 10, i would!
Reply With Quote
  #6 (permalink)  
Old 03-24-2016, 10:33 AM
Humblex's Avatar
Almost Senior Member
 
Join Date: Mar 2011
Location: Virginia
Age: 41
Posts: 535
Member #12086
Quote:
Originally Posted by VPRPWRD View Post
I just recently posted in a similar thread that adjustment of the parking brake switch is what I have found causing this issue most of the time.
Awesome brother, thank you!
VPRPWRD likes this.
Reply With Quote
  #7 (permalink)  
Old 03-24-2016, 10:38 AM
VPRPWRD's Avatar
VTCoA Ring Leader
Northeast VTCoA Regional Rep
 
Join Date: Mar 2012
Location: PA
Posts: 10,833
Member #13138
Quote:
Originally Posted by Humblex View Post
Awesome brother, thank you!
Not a problem! Let us know if that does fix your problem.
__________________
Quote:
Originally Posted by KyleB View Post
OMG, I think you're right! You're a genius, we should definitely put you in charge around here.
My YouTube channel:

http://www.youtube.com/channel/UCEsMsFATkTJq3k-BM26PfAg

Follow me on Twitter and Instagram: Andysavakinas



#1357 of 3057 2004 Dodge Ram SRT-10 SOLD!
#2718 of 3057 2004 Dodge Ram SRT-10
#0851 2006 Dodge Ram SRT-10 RC SOLD!
#292 of 3057 2004 Dodge Ram SRT-10 SOLD!

THE FORMER BUMP KING

i love the cognac interior of the gen1/gen2 viper. if i could do it to my 10, i would!
Reply With Quote
  #8 (permalink)  
Old 03-24-2016, 11:47 PM
Streetgliderx's Avatar
Almost Senior Member
 
Join Date: Oct 2008
Posts: 519
Member #8937
Check the plug to the master cylinder reservoir I unplugged mine once and forgot to plug it up. Chased the light and issues for two days.
__________________
"Everybody wants to go to heaven but their too afraid to die"

05 Yellow Fever QC #285 Current
Mopar headers, JTSV underdrive, JTSV Throttlebody, Unleashed Tuning, Borla Exhaust, Catless mids, T56 swapped QC. 464hp/498tq

04 Silver RC #564 SOLD
Reply With Quote
  #9 (permalink)  
Old 03-25-2016, 12:38 AM
VENOMOUS1 RACING's Avatar
Has Left the Room - Banned from VTCOA!
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 44
Posts: 12,753
Member #10675
Quote:
Originally Posted by AZBLACKMONSOON View Post
I'm having an intermitent problem of the red brake warning light coming on in the dash. It is not the ABS one, it is the red one like when you put the parking brake on. It also chimes when it turns on too. It only happens when I leave work in the very hot afternoon a few miles from work any other time it doesn't come on. I know I just won't goto work anymore. I have checked fluid level ,and the parking brake to make sure it is fully up. Any other ideas? Thanks
Gauge cluster issue in my experience, also tach will read low about 500 rpm at times then go back to normal. Only in 06 models has this been a consistent bug
Reply With Quote
  #10 (permalink)  
Old 05-12-2016, 07:41 AM
gatorowned's Avatar
Member
Northeast VTCoA Regional Member
 
Join Date: Jan 2013
Location: Jersey and Florida
Posts: 103
Member #13830
I have an 06...and mine does both brake light and low rpm (under 500). Is there a fix to this rather than replacing entire guage cluster? Seems if this was a wide spread problem...they would have a recall on it.
__________________
2006 Black RC
Magnaflow catback / BBK throttle body / CAI / JTSVP drop / blacked out grills, tails, lamps, headlights / SCT Tuner
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On






All times are GMT -4. The time now is 06:50 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum