Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > General Discussion
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

General Discussion

Chirp squeal on start up until warm


This is a discussion on Chirp squeal on start up until warm within the General Discussion forums, part of the Viper Truck SRT-10 Discussion category!
Mine chirped when cold after new Ac pump, the had a washer the wrong side of th compressor. I bet ...



Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 01-18-2018, 09:30 PM
THEWELSHM's Avatar
VIPER POWERED
 
Join Date: Aug 2008
Location: Brandon Florida
Posts: 2,314
Member #7432
Mine chirped when cold after new Ac pump, the had a washer the wrong side of th compressor. I bet your belt is out of alignment.

Thewelshm
Erobins likes this.

__________________

"Any day above ground is a good one"

"The trouble with socialism is that you eventually run out of other people's money to spend".

Margaret Thatcher
Reply With Quote
  #12 (permalink)  
Old 01-18-2018, 10:00 PM
Junior Member
 
Join Date: Aug 2016
Location: Miami fl
Posts: 66
Member #15883
I have taken the darn thing off like 4 times in last year but hey anything is possible my friend anytips on installing the belt at this point I'm willing to double triple check everything
Reply With Quote
  #13 (permalink)  
Old 01-18-2018, 10:12 PM
Almost Senior Member
 
Join Date: Apr 2015
Location: yelm WA
Posts: 558
Member #15071
Yep nothing like an annoying belt chirp to piss you off.
THEWELSHM likes this.
Reply With Quote
  #14 (permalink)  
Old 01-20-2018, 12:17 PM
Junior Member
 
Join Date: Aug 2016
Location: Miami fl
Posts: 66
Member #15883
The Welshm was correct the belt was not lined up correctly kept installing a little off alignment it would run over water pump pulley a bit too much to the rear i moved it up and this annoyance seems over for now .....thanks for the advice
THEWELSHM likes this.
Reply With Quote
  #15 (permalink)  
Old 01-20-2018, 10:35 PM
VENOMOUS1 RACING's Avatar
Has Left the Room - Banned from VTCOA!
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 44
Posts: 12,753
Member #10675
Check to ensure pulley isn't spinning on pump. Quite possible

Last edited by ViperJeff; 01-20-2018 at 11:13 PM. Reason: You know why
Reply With Quote
  #16 (permalink)  
Old 03-09-2018, 06:14 PM
Junior Member
 
Join Date: Aug 2016
Location: Hallettsville, TX
Posts: 44
Member #15873
Got an update on your issue erobins? I cranked mine up sitting a few hours and had no power steering. Then it started working again. I also heard a whirring noise. Iím 99% sure I need to change the pump. Will dive into it in morning when its cooled off.
Reply With Quote
  #17 (permalink)  
Old 03-10-2018, 12:06 PM
VIPER POWERED
Southwest VTCoA Regional Member
 
Join Date: Sep 2012
Location: Emory, Texas
Age: 71
Posts: 1,915
Member #13578
If the chirping be loud enough it help you not hear that annoying siren sound behind you.

Mine does not chirp but on raining mornings the power steering does not work till I turn the steering wheel back a forth a few times. Then all is well so go looking for the next victim.
Erobins likes this.
__________________
When you are dead, you donít know you are dead. It is difficult only for others. It is the same way when you are stupid.

Belanger headers, 3Ē aluminized pipe w/VX series mufflers, Venomous UD pulley, K&N FIPK Cold Air Kit, Roe Racing Throttle Body, MSD plug wires, Venomous Racing 2400 torque converter, HTS Valve Body and shift kit, SCT tuned by Chris Jensen and DR VIPER at Venomous Racing.
Reply With Quote
  #18 (permalink)  
Old 03-14-2018, 11:30 PM
Junior Member
 
Join Date: Aug 2016
Location: Hallettsville, TX
Posts: 44
Member #15873
Removed the belt and had taken a set in the parked position. Changed belt, fluids, no more issue. Working fine now.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Death Squeal! ViperCLKGTR General Discussion 2 05-09-2014 03:43 PM
** 4 Sale - CompuStar 1W900FM-AS Alarm/Remote Start Craig SRT-10 Trucks and Parts For Sale 9 08-08-2008 10:32 PM
died and no start silverqc General Discussion 21 01-04-2007 05:24 PM
Remote Start? tarheelguy General Discussion 17 11-03-2006 11:16 AM





All times are GMT -4. The time now is 01:38 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum