Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > General Discussion
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

General Discussion

Lowering and Caltracs Issue


This is a discussion on Lowering and Caltracs Issue within the General Discussion forums, part of the Viper Truck SRT-10 Discussion category!
Originally Posted by stealth78 Sorry guys, been years since I installed my JTSVP lowering kit but doesn't it come with ...



Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 10-03-2018, 09:52 PM
oldcolt's Avatar
Striker Heads and Cam
Canadian VTCoA Regional Member
 
Join Date: Jul 2008
Location: Calgary, AB
Age: 53
Posts: 2,643
Member #6209
Quote:
Originally Posted by stealth78 View Post
Sorry guys, been years since I installed my JTSVP lowering kit but doesn't it come with new bump stops, like stubs? Or was that the front and you simply just remove the rears in their entirety? Clearly I don't have a truck anymore or else I'd look.
You get new bump stops for the front, you have to cut down the rears.
stealth78 likes this.

__________________
Tuned by Chris Jensen


Reply With Quote
  #12 (permalink)  
Old 10-04-2018, 12:10 AM
6speedquadcab's Avatar
NorCal SF Bay Area
West VTCoA Regional Rep
 
Join Date: Nov 2014
Location: South Bay
Posts: 3,096
Member #14841
It’s nice to see people getting helped out on the forum like the good’ol days. Great job oldcolt.
oldcolt, TXThumper and stealth78 like this.
__________________
2006 Dodge Ram SRT-10 Quad Cab
Reply With Quote
  #13 (permalink)  
Old 10-04-2018, 04:35 AM
Junior Member
 
Join Date: Dec 2016
Posts: 29
Member #16210
Quote:
Originally Posted by oldcolt View Post
What issues are you having?
My blocks look exactly like the ones at the begining of this thread just smaller -

So my issue with the lowering block is that there is a stud coming off the bottom of the axle that is supposed to align the leaves. The lowering block only has a partial hole machined into it and a tiny stud like feature coming of the other side.

Firstly the stud will not fit under the axle, between the axle and the springs because of the stud coming off the bottom of the axle, its far too long to fit in the machined hole in the block.

Secondly the block's small stud thing does not fit into the alignment holes in the leaves. So even if I could put it there, how are the leaves then aligned? Considering they're only connected on one side, as I had to remove the overload leaf, which removed the second hard connection of all leaves, to fit the caltracs.

So in my mind, all my leaves will just sort of be clamped down onto one another, with no alignment and only one crimped metal holding them together? This doesnt seem correct, ive bought the kit from JTSVP. I'm sure this is of no fault of Tony or the product, this is me not figuring something out. Can anyone shed some light on the issue?

If anyone on this forum can help and uses whatsapp, I have a video explaining the issue, but cant send by email as the video is too big. My whatsapp is 00971505489714.

Last edited by Houb; 10-04-2018 at 04:38 AM.
Reply With Quote
  #14 (permalink)  
Old 10-04-2018, 09:33 AM
oldcolt's Avatar
Striker Heads and Cam
Canadian VTCoA Regional Member
 
Join Date: Jul 2008
Location: Calgary, AB
Age: 53
Posts: 2,643
Member #6209
Quote:
Originally Posted by Houb View Post
My blocks look exactly like the ones at the begining of this thread just smaller -

So my issue with the lowering block is that there is a stud coming off the bottom of the axle that is supposed to align the leaves. The lowering block only has a partial hole machined into it and a tiny stud like feature coming of the other side.

Firstly the stud will not fit under the axle, between the axle and the springs because of the stud coming off the bottom of the axle, its far too long to fit in the machined hole in the block.

Secondly the block's small stud thing does not fit into the alignment holes in the leaves. So even if I could put it there, how are the leaves then aligned? Considering they're only connected on one side, as I had to remove the overload leaf, which removed the second hard connection of all leaves, to fit the caltracs.

So in my mind, all my leaves will just sort of be clamped down onto one another, with no alignment and only one crimped metal holding them together? This doesnt seem correct, ive bought the kit from JTSVP. I'm sure this is of no fault of Tony or the product, this is me not figuring something out. Can anyone shed some light on the issue?

If anyone on this forum can help and uses whatsapp, I have a video explaining the issue, but cant send by email as the video is too big. My whatsapp is 00971505489714.
I had the same issue with the blocks from Tony. I simply drilled our the hole in the block to fit the alignment stud on the springs. Everything went together and I have had no issues in 8 or 9 years since I lowered my truck.
I am going to be away for a week, so hopefully this helps.

__________________
Tuned by Chris Jensen


Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On






All times are GMT -4. The time now is 08:15 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum