Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > General Discussion
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

General Discussion

Will not start, cranks, fuel pumps not shutting off....


This is a discussion on Will not start, cranks, fuel pumps not shutting off.... within the General Discussion forums, part of the Viper Truck SRT-10 Discussion category!
This is on a 2005 SRT10. I have had this happen 4 times now, 1st time about a month ago, ...



Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07-19-2017, 10:20 PM
Junior Member
 
Join Date: Jul 2017
Posts: 17
Member #17053
Will not start, cranks, fuel pumps not shutting off....

This is on a 2005 SRT10. I have had this happen 4 times now, 1st time about a month ago, and now its happened a few times since and I just now noticed the fuel pumps are not shutting off once I energize the key...
It will crank all day long, but not even try to fire up...after letting it sit from a minute or 2, it would fire up, and the pumps shut off after energizing the key and before pushing the START button.
I have 2 external puller pumps as well as the in the tank pump, all are on the same relay..they were added with the super charger install.
So that leads me to believe that maybe the intake pump is sometimes getting stuck, and is in a position so that the puller external pumps can't pull any fuel through the supply line to pressurize the system????

I guess next time this happens I need to quickly pull the supply line apart before the twin external pumps and see if fuel sprays out.

Any other ideas?

Reply With Quote
  #2 (permalink)  
Old 07-20-2017, 08:59 AM
Slitherbeast's Avatar
Twin Turbo, Forged
Canadian VTCoA Regional Member
 
Join Date: Sep 2007
Location: Alberta
Posts: 2,194
Member #2340
Does it happen when the gas tank is less than 1/4?
__________________
"Haters don't really hate you, they hate themselves cause you're a reflection of what they wish to be".


#993 04 blk RC 4.56 gears,Harland Sharp Rockers,3/8" Hardened pushrods PSI valve Springs,,striker Valve Cover spacers, JMB catless mids,Magnaflow catback, Torries' tune,Vec 2,B&M Shifter,Stinker's extreme lowering kit, Caltracs,catchcan, Forged Wiseco Pistons,Molnar Rods, Clevite bearings.Center Force Clutch,Cometics Head Gaskets,ARP head Studs , Pioneer X950BH Double Din touch screen with Nav , Grants Steering Wheel .And the list continues......
Reply With Quote
  #3 (permalink)  
Old 07-20-2017, 11:31 AM
VENOMOUS1 RACING's Avatar
Supporting Vendor
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 43
Posts: 12,580
Member #10675
I'd start with your relay but you may have fubared the pcm if it's triggering all 3 pumps. Check/swap fuel pump relay and ASD relay if you can.
__________________
"OFTEN imitated, NEVER duplicated"

Home of the SuperSnake hoods NOW AVAILABLE! :
Venomous1 Racing Traction/Transfer Systems coming to an SRT-10 near you
Venomous1 Racing Underdrive Pulleys for Gen3 SRT-10 Viper Trucks and Coupes available now!!

** 1 OF 5 2005 SRT-10 Quad Cab Tremec T56
Equipped**
Home of the First and Fastest 6 Speed SRT10 Quad Cab...The VENOMOUS1

Your Viper Coupe and Truck go fast and appearance parts GO-TO guy!!
Reply With Quote
  #4 (permalink)  
Old 07-20-2017, 06:09 PM
Slitherbeast's Avatar
Twin Turbo, Forged
Canadian VTCoA Regional Member
 
Join Date: Sep 2007
Location: Alberta
Posts: 2,194
Member #2340
How full is the tank? I had my pump inlet screen come out of it's perch and it would fall on it's face starting off. The pumps won't stop if they see air..... Once they stop and have pressure to the injectors it does start?
__________________
"Haters don't really hate you, they hate themselves cause you're a reflection of what they wish to be".


#993 04 blk RC 4.56 gears,Harland Sharp Rockers,3/8" Hardened pushrods PSI valve Springs,,striker Valve Cover spacers, JMB catless mids,Magnaflow catback, Torries' tune,Vec 2,B&M Shifter,Stinker's extreme lowering kit, Caltracs,catchcan, Forged Wiseco Pistons,Molnar Rods, Clevite bearings.Center Force Clutch,Cometics Head Gaskets,ARP head Studs , Pioneer X950BH Double Din touch screen with Nav , Grants Steering Wheel .And the list continues......
Reply With Quote
  #5 (permalink)  
Old 07-20-2017, 10:28 PM
Junior Member
 
Join Date: Jul 2017
Posts: 17
Member #17053
Tank is currently full. It did it again this eve, it has been sitting all day. So almost daily it will do this. Try a few times, let it sit a minute, then it works fine.
Today I put a fuel pressure gauge on the rail, of course after that it did not do it....
Yes, if the system pressurizes successfully (At least I think that is what is happening when they do shut off, will know when it does it again with the gauge on) Then it starts fine.
So I will leave it on and see if it will do it again tomorrow and see if I'm getting any pressure or fuel at all up to the rail.

The pumps have been wired that way for 7+ years. This should be how they are wired otherwise the external pumps would never shut off after priming when the key is on, but engine off.
rbabody likes this.
Reply With Quote
  #6 (permalink)  
Old 07-23-2017, 04:06 PM
Junior Member
 
Join Date: Jul 2017
Posts: 17
Member #17053
Ok, it finally did it again, the fuel system IS pressurizing, gauge indicates 58 psi, so no pump issues it appears, but for some reason it must think the system is not pressurized so the pumps keep running.

So, what sensor would be detecting if the system has pressure or not, and would it keep the ignition from firing if it thinks it is not pressurized??? I've read most of the fuel system part of the service manual and am not finding anything.

Thanks
Reply With Quote
  #7 (permalink)  
Old 07-24-2017, 09:59 PM
Junior Member
 
Join Date: Jul 2017
Posts: 17
Member #17053
Update, a friend of mine is a mechanic for a car lot, although he has never worked on a Viper or SRT10, his best guess is that the PCM is either seeing or reporting rpms when the key is turned on. Maybe a PCM issue, or whoever is feeding the rpm reading or used for calculating it is sending some voltage/pulses incorrectly.
There is no pressure switch that tells the pump to stop priming.
I confirmed this in the Service Manual, it indicates the pump just runs 1-3 seconds upon turning the ignition on, and they shut off unless the "Starter" is pushed, or the engine is running.

Recommends getting a scan tool hooked up to see what is being reported by the PCM....so off to find one...
rbabody likes this.
Reply With Quote
  #8 (permalink)  
Old 07-31-2017, 09:43 PM
Junior Member
 
Join Date: Jul 2017
Posts: 17
Member #17053
I disconnected the 2 puller pumps that were part of the Paxton setup. Problem finally occurred again, the in-tank pump does run for 3 secs and then shuts off as it is supposed to when key is turned on, but not pushing the START button, pressure in the rail goes to 58 psi.

Remember before the puller ext pumps would continue to run...so I assume then they are not tied to the fp relay, so the Paxton piggyback FMU unit must control them independently.
So I hooked up a volt meter to the leads for the ext puller pumps, I can't get it to register any voltage with key on to prime, or with the engine actually running..so I am not sure what controls them or how....seems like voltage would be commanded to them while engine is running even if the lead is disconnected as they ran before.. Guess I will hook them back up.

Maybe the Paxton FMU thinks the engine is already running also, and they are not commanded on when key is on and engine is off.....still need a scan tool.
rbabody likes this.
Reply With Quote
  #9 (permalink)  
Old 07-31-2017, 10:51 PM
rbabody's Avatar
Member
 
Join Date: Sep 2010
Posts: 352
Member #11773
When you say it did it again are talking about crank and no start or fuel pump running all the time? Yes find a scan tool or check for injector pulse and spark. Is your check engine light on?
Reply With Quote
  #10 (permalink)  
Old 07-31-2017, 11:23 PM
Junior Member
 
Join Date: Jul 2017
Posts: 17
Member #17053
Quote:
Originally Posted by rbabody View Post
When you say it did it again are talking about crank and no start or fuel pump running all the time? Yes find a scan tool or check for injector pulse and spark. Is your check engine light on?
Crank and will not start. So the fuel pump in the tank is just running for the 3 sec when the key is turned on and it shuts off then before the START button is hit...so it is acting normal. It's only the ext puller pumps that seem to continue to run ONLY when it will not start...I have them disconnected currently so I could hear the in-tank pump.
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Cells....do I need one? K-80-123 Performance Mods 23 11-23-2009 03:11 AM
CEL Code Question Rice Eater General Discussion 6 03-09-2007 01:19 PM
CEL @ 730 miles :( Get Bit General Discussion 32 08-11-2006 07:41 PM
NGK Powerdex AFX - Air Fuel Ratio Monitor - Wideband o2 Bone Performance Mods 2 07-13-2006 05:17 AM





All times are GMT -4. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum