Go Back   Dodge Ram SRT-10 Forum - Viper Truck Club of America > Viper Truck SRT-10 Discussion > Performance Mods
Home Forum Register FAQ Members List Social Groups Calendar Garage Mark Forums Read

Performance Mods

Compression test results?


This is a discussion on Compression test results? within the Performance Mods forums, part of the Viper Truck SRT-10 Discussion category!
Originally Posted by mopar-or-no-car 25% WOW. That is high MA Mopar. Shame on you And not less than 100 psi? ...



Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 01-11-2018, 11:18 AM
VENOMOUS1 RACING's Avatar
Has Left the Room - Banned from VTCOA!
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 44
Posts: 12,753
Member #10675
Quote:
Originally Posted by mopar-or-no-car View Post
25% WOW. That is high MA Mopar. Shame on you
And not less than 100 psi? Shit I hope not. It's obviously a generic spec they throw at all models because each car says the same thing in tech manual.

Reply With Quote
  #12 (permalink)  
Old 01-13-2018, 05:01 PM
Junior Member
 
Join Date: Aug 2016
Location: Hallettsville, TX
Posts: 44
Member #15873
175 psi

When inought my truck at 80,000 miles it tested 165-175 psi on all cylinders.
VENOMOUS1 RACING likes this.
Reply With Quote
  #13 (permalink)  
Old 01-14-2018, 09:45 AM
VENOMOUS1 RACING's Avatar
Has Left the Room - Banned from VTCOA!
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 44
Posts: 12,753
Member #10675
Quote:
Originally Posted by Super Dave View Post
When inought my truck at 80,000 miles it tested 165-175 psi on all cylinders.
Exactly where it should be!
Reply With Quote
  #14 (permalink)  
Old 01-19-2018, 07:33 AM
Senior Member
 
Join Date: Jun 2006
Location: Phoenix, AZ
Posts: 1,304
Member #249
I've spent this summer/fall/winter doing some restoration on my 170K mile truck. New paint overall but lots of mechanical replacements. I've been collecting OEM new parts the last couple years as many of our suspension, water pumps, injectors etc are getting hard to come by. Just finished up the engine bay (last thing) and decided to do a compression check... Darn thing was 170-175psi across all the cylinders. It still doesn't burn any oil.

On a negative note; truck has an inconsistent idle now when cold. Once it warms up its rock steady. I had the intake manifold off to replace coils/wires. Did new injectors, valve cover gaskets, intake gaskets, water pump etc. First thought was intake leak, however, the design/gaskets used makes it almost idiot proof. Suggestions? Except for that one bolt pulling the intake isn't that big a deal.
Psycho1122 likes this.
__________________
Chuck B
Phoenix
SRT-10 RC 170K Mile Member
Yamaha XT1200Z
Honda Rune
Triumph 675
Ducati GT1000s
Honda VFR1200
Honda GB500
Kawi KLR650 x2
BMW R100RT
Reply With Quote
  #15 (permalink)  
Old 01-19-2018, 07:45 AM
Psycho1122's Avatar
Almost Senior Member
Southwest VTCoA Regional Member
 
Join Date: Jan 2010
Location: The "Crazy" Far East part of Mesa, AZ
Posts: 896
Member #11268
A few things if I may ask....

Nice Compression #'s!!

What oil / filter have you been using and how often do you change it? Also, how often do you start it?

When it comes to inconsistent idle, have you addressed your O2 sensors in the exhaust?

Cheers!
__________________
2005 Black RC Born on April, 22nd., 16th hour of 2005: BBK, JTSVP Gen II Shifter, JTSVP Under Drive Pulley, K&N Drop-In, Demon Coils, B&B Manifold Back Exhaust w/ Hi flow Cats, SCT Tuned by Torrie, RX Monster Catch Can, JMB QA1 "kicker" shock, Polyurethane Suspension / Sway bar Bushings, AEM Wideband, Raptor Shift Light, Dynamat Interior, JTSVP Oil Cooler lines, 70/30 DiH2O/Dexcool Mix w/ Water Wetter, ALL fluids Synthetic and a few "sneaky" aero mods

2000 ZX1270R, 200 H.P. / 111 Ft. Lbs.
Reply With Quote
  #16 (permalink)  
Old 01-19-2018, 08:05 AM
VENOMOUS1 RACING's Avatar
Has Left the Room - Banned from VTCOA!
Southwest VTCoA Regional Member
Southwest VTCoA Regional Rep
2013 Viper Truck of The Month
 
Join Date: May 2009
Location: Wacko Waco,TX
Age: 44
Posts: 12,753
Member #10675
I agree, O2 sensors degrade and are often overlooked as part of an engine build or freshening. Assume you're running stock 438 Champion? If not we found your Miss
Reply With Quote
  #17 (permalink)  
Old 01-21-2018, 10:44 PM
Senior Member
 
Join Date: Jun 2006
Location: Phoenix, AZ
Posts: 1,304
Member #249
Quote:
Originally Posted by Psycho1122 View Post
A few things if I may ask....

Nice Compression #'s!!

What oil / filter have you been using and how often do you change it? Also, how often do you start it?

When it comes to inconsistent idle, have you addressed your O2 sensors in the exhaust?

Cheers!
I was a bit surprised on the numbers myself. I've only used OEM specified oil (Mobile 0-40) and have changed it and OEM Viper oil filter religiously every 3000 miles. Thats about 55 oil changes!

While I was living in Flagstaff the last 6yrs I left the truck here in Phx. I took it out for a drive maybe once every couple months. Going back thru my records I've been averaging about 1500 miles a year. We are back in Phx now and now driving it once or twice a month.

O2 sensors...that was also part of my mechanical upgrades the last few months. I went with full Billy Boat exhaust with stock headers. Secondary O2's are connected to simulators. Running primary only and no cats. Truck ran fine before all the mechanical work I did.
Psycho1122 likes this.
__________________
Chuck B
Phoenix
SRT-10 RC 170K Mile Member
Yamaha XT1200Z
Honda Rune
Triumph 675
Ducati GT1000s
Honda VFR1200
Honda GB500
Kawi KLR650 x2
BMW R100RT
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Famoso Test and Tune 2-1-2014 Results Trainman Ram Srt-10 Racing 7 02-04-2014 11:41 AM
Atco test and tune 4/7 RESULTS with pics and videos VPRPWRD Ram Srt-10 Racing 10 04-09-2013 09:01 AM
Compression Test Results. Variance is too high? robwclark General Discussion 13 07-14-2009 04:18 AM
My first post! Compression test & oily spark plug question. robwclark Performance Mods 14 06-26-2009 09:10 PM
Complete braided brake line kit, and oil lines JTS VENOM PERFORMANCE General Discussion 65 09-25-2007 07:20 PM





All times are GMT -4. The time now is 04:01 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO
vB.Sponsors
This site is supported by its members, vendors, and administration. Vtcoa.com is in no way affiliated with Daimler Chrysler. Dodge, Viper,Ram SRT-10, the Viper logo and likeness are registered trademarks of Daimler Chrysler. The contents of this site are owned by Vtcoa.com and may not be used or reproduced without the express written permission of the Administrator.
GM Truck Forum
Ford Raptor Forums
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Sotball Forums
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum