rottenronnie's Recent Activity

  1. rottenronnie posted a new thread.

    Back in 2005...

    I sure miss the sheer number of active members that used to be on this Forum. Back then, dedicated individuals were hard at work...

    Forum: General Discussion

    Jul 3, 2020 at 9:02 PM
  2. rottenronnie liked shorty's post in the thread BEST GAS MILEAGE.

    21 MPG-------9 in town and 12 on the hwy = 21 here in TEXAS

    Jul 3, 2020 at 11:36 AM
  3. rottenronnie replied to the thread MOPAR Stainless Headers.

    PS Don't get talked into Header Wrap/Blankets instead of ceramic coating. They are excellent for trapping moisture and speeding up rust.

    Jul 2, 2020 at 1:43 PM
  4. rottenronnie replied to the thread MOPAR Stainless Headers.

    I'm in Calgary, Canada and it cost me around $280.00 For you in the United States, it will likely be around $24.95 :) Make a few calls...

    Jul 2, 2020 at 1:39 PM
  5. rottenronnie liked Kiwi SRT10's post in the thread BEST GAS MILEAGE.

    Redneck Edition Dual Duals:D Oh yeah, only sick hundred hp

    Jul 1, 2020 at 6:12 PM
  6. rottenronnie replied to the thread BEST GAS MILEAGE.

    800 horsepower. :p

    Jul 1, 2020 at 5:56 PM
  7. rottenronnie replied to the thread BEST GAS MILEAGE.

    18 Imperial

    Jul 1, 2020 at 5:45 PM
  8. rottenronnie replied to the thread New To Me.

    That works out to 21 Imperial MPG, which is amazing. I don't/can't use the Overhead Calculator myself as I've changed to a larger...

    Jul 1, 2020 at 5:44 PM
  9. rottenronnie replied to the thread MOPAR Stainless Headers.

    Carefully tether the ganglia found there to the heater hoses (general area) with a couple or 3 tie-wraps, done.

    Jul 1, 2020 at 2:27 PM
  10. rottenronnie liked AMS3's post in the thread Need Help.

    Condolences Kiwi.

    Jul 1, 2020 at 11:43 AM
  11. rottenronnie replied to the thread MOPAR Stainless Headers.

    A couple of things: I'd use the Mopar exhaust gaskets AND have the headers ceramic-coated. Watch for wiring at the rear, passenger side.

    Jul 1, 2020 at 11:43 AM
  12. rottenronnie liked TrailMix's post in the thread Need Help.

    It might be a ground issue. You might to run ground cable straight from the battery down to one of starter bolts.

    Jun 30, 2020 at 4:26 PM
  13. rottenronnie replied to the thread Need Help.

    Speaking of porcelain... too much coffee!!!

    Jun 30, 2020 at 4:25 PM
  14. rottenronnie replied to the thread Need Help.

    Except for spark plugs as the energy from the firing tip is supposed to jump to the electrode (ground); but a vehicle sitting on tires...

    Jun 30, 2020 at 4:22 PM
  15. rottenronnie liked Kiwi SRT10's post in the thread Need Help.

    Working on these is always a ground issue....I hate lying on the ground too hahahaha. But it always seems to be where the jobs are.

    Jun 30, 2020 at 4:15 PM