Need help

Discussion in 'Forum Requests' started by The-bullet22, Mar 16, 2018.

  1. The-bullet22

    The-bullet22 Full Access Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 24, 2017
    Location:
    Tucson,az
    I have a problem with the truck bringing up a P0340 camshaft position sencor signal lost and im having a had time identifying what wire on the harness thats connects to the camshaft postion sensor it could be. Its has a new camshaft positin sensor. The truck will turn over and run when it wants to on a good day but on a bad day it wont start up and just will just turn over all day when trying to start it. if there anybody that had the same problem that can give me a recommendation or tips to check. It would be muchly appreciated.
    Seems like the truck is having a bad week with wiring harness for camshaft position sensor.
     
  2. VENOMOUS1 RACING

    VENOMOUS1 RACING Has Left the Room - Banned from VTCOA!

    Messages:
    12,753
    Likes Received:
    1
    Joined:
    May 15, 2009
    Location:
    Wacko Waco,TX
    Was sensor installed at correct depth? It's very crucial! If so swap crank sensor as it's likely culprit.
     
  3. The-bullet22

    The-bullet22 Full Access Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 24, 2017
    Location:
    Tucson,az
    Yes its set at the right depth that the camshaft is sitting at. I had a mechanic near me that has the same srt10 year of the truck check and go over it on depth of it.
     
  4. tomdragoo

    tomdragoo Full Access Member

    Messages:
    33
    Likes Received:
    0
    Joined:
    Dec 28, 2017


    Unplug the wire harness and reset your Ecu then reconnect the harness. Pull the pcu ecu fuse when it is running!


    Sent from my iPhone using Tapatalk
     
  5. The-bullet22

    The-bullet22 Full Access Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 24, 2017
    Location:
    Tucson,az
    Okay ill do that.
     
  6. VENOMOUS1 RACING

    VENOMOUS1 RACING Has Left the Room - Banned from VTCOA!

    Messages:
    12,753
    Likes Received:
    1
    Joined:
    May 15, 2009
    Location:
    Wacko Waco,TX
    Dont recommend that^^
    Swap crank sensor
     
  7. The-bullet22

    The-bullet22 Full Access Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 24, 2017
    Location:
    Tucson,az
    Well the old cam sensor isnt good because it got shredded by the timing chain. So i had to replace the timing gear and got the new sensor in it like i said set at the axact depth its at right now. And crank sensor?
     
  8. The-bullet22

    The-bullet22 Full Access Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 24, 2017
    Location:
    Tucson,az
    Now thats its been a day of me of trying to find the problem of the camshaft ppsition sensor. The check engine light flashes 11 time then on the 12th time it short flashs and goes solid light. Do u know what that means possible?
     
  9. VENOMOUS1 RACING

    VENOMOUS1 RACING Has Left the Room - Banned from VTCOA!

    Messages:
    12,753
    Likes Received:
    1
    Joined:
    May 15, 2009
    Location:
    Wacko Waco,TX
    Need to swap crank sensor as I said and ensure cam
    Sensor is installed at correct depth. If your old sensor got chewed by timing gear it wasnt installed right!!!