Radio Amp Getting Hot..

Discussion in 'General Discussion' started by TNVIPER, Jul 30, 2006.

Car Parts
  1. TNVIPER

    TNVIPER Active Member Supporting Member

    Messages:
    12,804
    Likes Received:
    1
    Joined:
    Jul 25, 2006
    Location:
    God's Chosen Land....East TN
    This may have been discussed before but since I am new ya'll look over me..;)

    The amp in the storage compartment under the middle front seat is hot as he!! (I cannot keep my hand on it for more than a few seconds) and the radio is not even on...is this normal or has this been a common problem?:confused:
     
  2. RedSrt007

    RedSrt007 Active Member Staff Member

    Messages:
    5,622
    Likes Received:
    0
    Joined:
    May 17, 2006
    Location:
    San Diego,Ca
    Sounds like a problem....at least mine stays cool all the time:dontknow: :confused: :dontknow:
     
  3. 1-FAST-SRT-10

    1-FAST-SRT-10 Full Access Member

    Messages:
    610
    Likes Received:
    0
    Joined:
    May 18, 2006
    Location:
    Montreal , Canada
    You need to upgrade ,OEM audio sucks...
     
  4. ILtemprd

    ILtemprd Full Access Member

    Messages:
    3,019
    Likes Received:
    0
    Joined:
    May 18, 2006
    What he said.
     
  5. v8eater

    v8eater Full Access Member

    Messages:
    360
    Likes Received:
    0
    Joined:
    May 24, 2006
    Location:
    In the state of a deep trance.
    I've got a couple of songs in my collection that are guaranteed to overheat the speaker coils (and they do!:rock:). The amp warms up, but not too hot to touch. Your system probably has a defect. Crank it 'till it blows up and get it replaced under warranty.:thrasher: :thrasher:
     
  6. 1-FAST-SRT-10

    1-FAST-SRT-10 Full Access Member

    Messages:
    610
    Likes Received:
    0
    Joined:
    May 18, 2006
    Location:
    Montreal , Canada
    Thats what i'm talkin about...eehhh
     

    Attached Files:

  7. BLACK10

    BLACK10 Full Access Member

    Messages:
    51
    Likes Received:
    0
    Joined:
    May 18, 2006
    Location:
    Panama City FL
    I would gut the factory system and get some JL Audio components,10" w3v2 sub and a 300/4 and you will see a huge difference in sound quality and fix the amp prob at the same time
     
  8. TNVIPER

    TNVIPER Active Member Supporting Member

    Messages:
    12,804
    Likes Received:
    1
    Joined:
    Jul 25, 2006
    Location:
    God's Chosen Land....East TN
    Welll..seems this is not a common problem...guess I will visit the dealer as a warranty issue...thanks for the responses..:star:
     
  9. Jeff

    Jeff New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    May 19, 2006
    Location:
    Massachusetts
    amps get hot when used. should be totally normal.
     
  10. TNVIPER

    TNVIPER Active Member Supporting Member

    Messages:
    12,804
    Likes Received:
    1
    Joined:
    Jul 25, 2006
    Location:
    God's Chosen Land....East TN
    Took it to my dealer...it was so hot you could not touch for more than a second w/o being burned...dealer has ordered replacement under warranty....:)