spedo cluster static(blinking)help!

Discussion in 'General Discussion' started by Tito#14SRT, Nov 7, 2011.

Car Parts
  1. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    So im driving my 10 this morning and my cluster starts acting up?! On the odometer where miles shows that blinks...park brake blinking...airbag light goes on and off blinking and beeping everything else seems fine, radio lights. I checked my ground on my battery post and positive and seems to be good
     
  2. wesalbert

    wesalbert 2015 Truck of the Year Supporting Member

    Messages:
    9,774
    Likes Received:
    0
    Joined:
    Feb 26, 2008
  3. FastRam

    FastRam Full Access Member

    Messages:
    1,551
    Likes Received:
    0
    Joined:
    Feb 12, 2008
    Location:
    N. VA
    Try disconnecting the battery, both pos and neg and let it sit for about 15 or 20 minutes, then reconnect. As wes mentioned, a dealer visit maybe in your future.
     
  4. SrtBrad

    SrtBrad Michel Productions

    Messages:
    12,868
    Likes Received:
    3
    Joined:
    Feb 10, 2007
    Location:
    North from City of Angels (Lancaster}
    bad battery or alternator
     
  5. vmf700

    vmf700 New Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Aug 21, 2006
    Location:
    Raleigh, NC
    Most likely a bad alternator as SrtBrad points out. The alternator is not charging the battery forcing the vehicle to run off pure battery power. As it falls under 11.1 volts, or thereabouts, it begins to wreck havoc on the electrical systems connected to the ECM either directly or indirectly. My 2-cents.
     
  6. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    Last edited: Nov 7, 2011
  7. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
  8. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    i disconnected positive cable off battery while truck was at idle in driveway to check if alterator is bad...truck stays on no problem went ahead and disconnected the negative side as well and truck seems to run fine alternator is doing its job so its not the alternator or battery....i have to have a bad ground somewhere imma have to take the cluster out and check harness make sure there re plugged in all the way follow ground connection maybe...
     
  9. ZCx

    ZCx Active Member Supporting Member

    Messages:
    9,787
    Likes Received:
    5
    Joined:
    Sep 13, 2007
    Location:
    Big D
    door switch????:confused:
     
  10. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    what do you mean by door switch?
     
  11. ZCx

    ZCx Active Member Supporting Member

    Messages:
    9,787
    Likes Received:
    5
    Joined:
    Sep 13, 2007
    Location:
    Big D
    the one that lights up the odometer & dome light when ya open the door
     
  12. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    Any ideas where that might be located?
     
  13. Slitherbeast

    Slitherbeast Well-Known Member Supporting Member

    Messages:
    2,280
    Likes Received:
    29
    Joined:
    Sep 10, 2007
    Location:
    Alberta
    check for error codes?
     
  14. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    I would probably have to take it to dealer to check if it has any codes?
     
  15. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    Imma take cluster out and check all 3 plug in connections wires etc. Before i make a trip to dealer...since a fuse blew once in cluster and i had to replace it once already. Good thing it was under warranty cluster is like $600 or so and they have fuses internally so if one has a short or blows need to change the whole thing
     
  16. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    I dont think its that since...door switch only turns odometer on and its making not only the odometer blink but also park brake and airbag plus turn signals will be really staticly in cluster when turning either one all tho outside light bulbs blink normal without any issues
     
    Last edited: Nov 8, 2011
  17. FastRam

    FastRam Full Access Member

    Messages:
    1,551
    Likes Received:
    0
    Joined:
    Feb 12, 2008
    Location:
    N. VA
    What caused the fuse to blow? And I thought all the fuses were in the box under the hood :dontknow:
     
  18. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    I use to think the same until that happen to me...and i took it to the dealer and apparently our clusters have like 3 fuses internally and if they have a short or go bad there is no way on replacing you have to get a brand new cluster which are pretty expensive IMO I only had to pay $100 deductible because of my warranty but they are like $600 or more i cant remember now. And I think what caused the short was actually my fault, I had wired something and didnt disconnect the battery negative cable.
     
  19. wesalbert

    wesalbert 2015 Truck of the Year Supporting Member

    Messages:
    9,774
    Likes Received:
    0
    Joined:
    Feb 26, 2008
    How long ago did they replace it. Wouldn't this one fall under some kind of warranty?
     
  20. Tito#14SRT

    Tito#14SRT Full Access Member

    Messages:
    1,150
    Likes Received:
    0
    Joined:
    Dec 29, 2009
    Location:
    Tampa,FL
    I have to check my reciepts....also I think my warranty is no longer valid.
    but I drove it around today and nothing....everything working fine its gotta be something minor im just real picky, like everything to be just right you know.
    so imma first take a look at cluster and take it out myself( which i changed out the first time at the dealer since I use to work there before and I know the service manager and all the techs there) and just see if its that maybe the plug is not completely "clipped" in or something inspect the wirring...and if I cant seem to find nothing and it keeps acting up imma just take it in have them check for codes see if they can figure it out.