Shifter question

Discussion in 'General Discussion' started by ty.thompson1981, Aug 24, 2016.

  1. NukeGM/Ford

    NukeGM/Ford Active Member

    Messages:
    1,786
    Likes Received:
    8
    Joined:
    Oct 4, 2014
    Location:
    North Las Vegas, NV
    you said you have a venom shifter, do you mean Tony at JTSVP or is the brand really Venom??
    probably the solenoid for the lockout. mine does it almost all the time when its hot, only sometimes when its cold. turn the truck off and it goes right in immediately. need to get my fat arse under the lowered truck to remove it. i wouldn't worry about going into reverse at speed if you get that far over it will grind some first anyway. proper hand position will prevent you from going that far
     
  2. ty.thompson1981

    ty.thompson1981 Full Access Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Aug 24, 2016
    Hey guys sorry I haven't posted in a bit. I don't know if its the solenoid because when I remove the shifter all entirely and use a ratchet extension, I can put the trans in reverse with no issue. When I put the shifter on, sometimes it won't go far enough to the right to find reverse. Sometimes it will. I got the shifter used and was told it was a venom shifter. Plus shifting around town its kinda notchy. The clutch is bled fine and the trans is newly rebuilt. That's why I'm thinking the shifter internals maybe worn. I contacted the company that makes the shifter and they said they can sell me a kit that includes the adjustment springs and screws. I was hoping they sold the other little pieces in the shifter as well like the little c shaped pieces and the little circular plates that are in there. They don't sell the other pieces.
     
  3. ty.thompson1981

    ty.thompson1981 Full Access Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Aug 24, 2016
    Does anyone know if a cobra t56 shifter would fit the t56 on these trucks? I heard the surface area is the same on both transmissions. Anyone know for sure?
     
  4. Slitherbeast

    Slitherbeast Active Member Supporting Member

    Messages:
    2,250
    Likes Received:
    7
    Joined:
    Sep 10, 2007
    Location:
    Alberta
    definitely hitting the solenoid.
     
  5. ty.thompson1981

    ty.thompson1981 Full Access Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Aug 24, 2016
    So far reverse hasn't given me a problem. Ive been driving the truck around for the last few days including 2 days to work which is 30 minutes each way mostly highway. The shifter feels pretty notchy. Hard to find gears when trying to downshift. Release it out of a gear and it doesn't really return back to neutral. I have to physically shake it a few times.
     
  6. Slitherbeast

    Slitherbeast Active Member Supporting Member

    Messages:
    2,250
    Likes Received:
    7
    Joined:
    Sep 10, 2007
    Location:
    Alberta
    It is out of adjustment. BIG TIME! Trouble with adjustable shifters is that they are adjustable. a wrench in the wrong hands can create all kinds of problems. you will need to find the original Neutral position. good luck
     
  7. ty.thompson1981

    ty.thompson1981 Full Access Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Aug 24, 2016
    Thanks. I'm afraid to mess with the adjustment now that reverse has been working without an issue lol. I'll mess with it and see what happens. Anyone know for sure if an 03/04 cobra shifter would fit this trans? I read somewhere that they might but not sure. Just keeping options open in case I need a new shifter.
     
  8. Ponchopwr70

    Ponchopwr70 Full Access Member

    Messages:
    124
    Likes Received:
    1
    Joined:
    Apr 27, 2015
    I know when I re-installed my shifter after putting in a clutch I had some problems going in reverse. What I read was to install with all the bolts slightly loose, shift through the gears then put the shifter into 3rd and then tighten. My reverse 5% of the time will bust my balls but it's been fine lately.
     
  9. ty.thompson1981

    ty.thompson1981 Full Access Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Aug 24, 2016
    Good deal. For the past few days that I've been driving the truck reverse has been fine. Now downshifting is the issue. Can't find gears.
     
  10. Slitherbeast

    Slitherbeast Active Member Supporting Member

    Messages:
    2,250
    Likes Received:
    7
    Joined:
    Sep 10, 2007
    Location:
    Alberta
    You need to bleed the clutch slave/Master. Sounds like the clutch isn't disengaging enough to allow gear changes .
     
  11. ty.thompson1981

    ty.thompson1981 Full Access Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Aug 24, 2016
    Clutch is bled. Firm pedal throughout the travel. I wish u were in my area to feel the shifter. Hard to explain what I'm experiencing. One of my coworkers sat in my truck with it not running and was playing with the shifter. He agreed the shifter felt weird. He said it definitely felt like it was either out of adjustment or something was going on with it. Best way to describe it is when u grab the shifter to shake it to make sure it's in neutral, it feels like it gets hung up and not in neutral. Once u wiggle it a few times the shifter loosens up a bit and then it feels like its in neutral. While driving it shifts ok on the upshifts. Not great but it doesn't give any trouble going 1-6. Definitely can't speed shift or power shift. Downshifting takes some doing. Pull it out of gear and the shifter doesn't go into neutral. Feels like it gets hung up in the gate for a second and I have to wiggle it a little bit to break free from what ever gear it was in then I'm able to put it in a lower gear. Takes a couple seconds to do all that and execute an actual downshift
     
  12. ty.thompson1981

    ty.thompson1981 Full Access Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Aug 24, 2016
    If anyone has a b&m that would want to trade for a jts venom shifter let me know. I can't seem to get this one adjusted properly. Hit me up here with a phone number. It won't let me post in the parts section I guess because I'm a new member.