Seats

AMS3

Full Access Member
Joined
Aug 8, 2019
Messages
1,072
Reaction score
775
Location
Savannah Ga
So, I need some help. Both front seats have frozen incline/decline levers. Luckily they are in a position where the seats are comfortable. How can I get them functional again? My driver side moves fwd and backwards, and the tilt up works. Problem is my rear up/down. When I toggle the switch, it makes noise and tries to move but doesn't. I've tried X2 for parts, but they don't have any. Any advise, ideas on how to correct these problems? Been like this since I bought the truck. Once again, I should have been more thorough with inspecting the truck before giving the owner the cash... Sadly, all I saw was an SRT10, and fell in love with it. It's been a labor of love, LOL!
 
pretty sure you need a seat track. same thing happened to my 04 hemi ram. the adjuster buzzes and gets stuck in the full foward position. I remember when I first purchased the truck, i was at the car wash vacuuming it out and the seat got stuck, I almost needed a tow. I messed with it, and figured out if you toggle it in increments, it worked. if you full blown hold the switch, it just takes a crap altogether. slow and steady. almost positive you can't just get the motor.
 
pretty sure you need a seat track. same thing happened to my 04 hemi ram. the adjuster buzzes and gets stuck in the full foward position. I remember when I first purchased the truck, i was at the car wash vacuuming it out and the seat got stuck, I almost needed a tow. I messed with it, and figured out if you toggle it in increments, it worked. if you full blown hold the switch, it just takes a crap altogether. slow and steady. almost positive you can't just get the motor.
Yeah, I hit up X2 Builders, they don't have the parts. I'm not too worried about the up and down in the back, as I am about the manual release handle for the backrest. It's really odd that both front seats are frozen. Here's a thought, ARE they supposed to decline/incline? Or are they set in that position,and the handle is just for looks...(doubtful).
 
To be honest, I forgot they were even there. I went out to the shop just now and tried mine and they are working just fine.
I know it doesn't help you out..
Sorry. They "feel" like it may be a cable in there. Again, YouTube may provide some insight.
 
To be honest, I forgot they were even there. I went out to the shop just now and tried mine and they are working just fine.
I know it doesn't help you out..
Sorry. They "feel" like it may be a cable in there. Again, YouTube may provide some insight.
Yeah, I'll have to youtube it. I tried twisting the passenger side but stopped. Didn't want to strip the handle.
 
check for coins stuck in the seat track. i recall the motors are the same as any other ram with power seats, so you could order a new one and try that.
as far as the handle, try and release the handle and move the seatback with your hand to see if anything is trapped in the gear.
 
check for coins stuck in the seat track. i recall the motors are the same as any other ram with power seats, so you could order a new one and try that.
as far as the handle, try and release the handle and move the seatback with your hand to see if anything is trapped in the gear.
Thanks for the info, guys. I'll look at it this weekend.
 
I had my recline lever get froze up. It was in a decent position so it didn't bother me. Left a car show and seat got stuck all the way back. Took seats out took recline assembly apart. Plenty of elbow grease was required but got it working.
 
Thanks for the info, guys. I'll look at it this weekend.
Did you fix the problem ? My passenger side has a problem with the power tilt only .. one of the motors I’m guessing it does make the normal noise , just not moving the seat ! Looking for the easy fix ? I mean hell I’m in the drivers seat .
 
I fixed the recline lever. I had one motor on drivers seat either not working or not moving the seat, I don't quite remember. Probably should have looked at it while I had the seats out.
 
I fixed the recline lever. I had one motor on drivers seat either not working or not moving the seat, I don't quite remember. Probably should have looked at it while I had the seats out.
One of these days I’ll have to pull the seat and go for the fix ! Procrastination over the last few years has become my middle name . it one of the mortars won the passenger side so doesn’t affect me driving hahaha
 
One of these days I’ll have to pull the seat and go for the fix ! Procrastination over the last few years has become my middle name . it one of the mortars won the passenger side so doesn’t affect me driving hahaha
Drivers seat. Button towards the front. Makes a buzzing sound both directions but won't move. I remember why I didn't bother when seats were out. I was more worried about the perma recline position than the other adjustments. Then obviously no power to motor once I unplugged the harness. Probably just froze up from lack of use. Screenshot_20240308_195545_Gallery.jpg
 
Boy if that's the case I better not touch mine! Hasn't been driven in years lol
 

Latest posts

Support Us

Become A Supporting Member Today!

Click Here For Details

Back
Top